Jump to content
Header für Profilseite J. Wigandt

J. Wigandt

Mitarbeiter
  • Gesamte Inhalte

    30
  • Benutzer seit

  • Tagessiege

    10

J. Wigandt hat zuletzt am 20. November 2018 gewonnen

J. Wigandt hat die beliebtesten Inhalte erstellt!

Reputation in der Community

31 Gut

1 Benutzer folgt diesem Benutzer

Über J. Wigandt

  • Rang
    Stammgast

Persönliche Informationen

  • Branche
    Dienstleistung
  • Fachgebiet
    Webentwicklung

Letzte Besucher des Profils

1.370 Profilaufrufe
  1. Hallo Barbara, weiß jetzt nicht genau ob du die Übertragung von VARIO zu Gambio beheben konntest aber ich leg einfach mal los Hier schlägt die Authentifizierung fehl, weil unter "/admin/vario7/key.vario" der Authentifizierungsschlüssel hinterlegt ist und du diesen beim normalen Browseraufruf nicht mit übergibst. VARIO übergibt den in Filialeinstellungen hinterlegten Schlüssel bei Aufrufen (Diese müssen übereinstimmen): Wenn diese nicht übereinstimmen, dann kommt der Authentifizierungsfehler - So wie beim normalen Browseraufruf. Zum Testen kannst du da einfach die Datei "key.vario" löschen und erstmal ohne Schlüssel probieren zum Laufen zu bekommen (Dann findet keine Prüfung statt). Das sind die normalen "deprecated warnings" von PHP, die funktionieren aber noch. Aber im Gesamtkontext hört es sich so an als ob die FTP-Verbindung einfach nicht funktioniert und der Rest klappt, weshalb du keine Bestellungen abholen kannst (Wenn die Dateien erzeugt wurden. Nachdem VARIO diese abholt, werden diese immer gelöscht) und den API Key nicht automatisch übertragen werden konnte. Müsste aber durch Replikationslog durch mehrere Verbindungsversuche, Authentifizierungsfehler, etc. erkennbar sein.
  2. Hallo Herr Scholz, das ist richtig, dass aktuell auch aus Textfeldern Zeilenumbrüche bei der Übertragung an Shopware entfernt werden. Habe es an die Entwicklungsabteilung weitergegeben, sollte auch für VARIO 8.0 zurück gepatcht werden.
  3. Dieser Fehler entsteht wird durch das Gambio Modul G-Protector ausgelöst. Dieses schützt vor "Angriffen und unsachgemäßer Änderung in Gambio Admin". Unsere Schnittstelle wird von diesen Modul nicht berücksichtigt. Können Sie es deshalb entfernen und nochmal probieren?
  4. Hallo Rene, ist bisschen widersprüchlich, da die Replikation besagt, dass die Tabelle vario_adr nicht existiert, auf der anderen Seite in Ihren Screenshot von phpMyAdmin existiert es zu keinen Fehler in der vario_dbupdates7 kommt. Auch die DB Version ist korrekt (8.0.000.000). Um das ganze etwas zu beschleunigen können Sie mir da die FTP-Zugangsdaten und Shop-URL via PN senden damit ich dies untersuchen kann?
  5. Bitte die vario_dbupdates7.php aufrufen und Screenshot posten Falls mit Tabellen irgendwas schief gelaufen ist wird es dort sichtbar sein
  6. Hallo Rene, bzgl. Tabellen haben Sie es schon fast raus, wenn die API installiert wird kann es die Datenbankupdates erst bei Aufruf der Schnittstelle fahren, deswegen stößen Sie da auch auf Fehler wenn Sie versuchen direkt zu importieren. (Beim Import werden DB Updates nicht ausgeführt). Um sicher zu gehen ggf. können Sie via FTP die Datei /admin/vario7/key.vario kurz umbenennen und via HTTP http://#SHOP_URL#/admin/vario_dbupdates7.php aufrufen. Dort sollten Sie (falls was aktualisiert wird) eine Liste von MySQL-Queries sehen die auf der Datenbank ausgeführt werden (Da sehen Sie auch ggf. auftretende Fehler - falls welche auftauchen). Wenn Sie auf den aktuellen Stand der Datenbank sind wird oben einfach nur die aktuelle Versionsnummer. Dann können Sie die key.vario Datei wird auf originalen Namen umbenennen.
  7. Hallo stetra, habe die Schnittstelle nun untersucht. Bei Ihnen war eine ältere Version der Schnittstelle (8.0.000.018) installiert - da waren die Anpassungen für das DSGVO Update noch gar nicht drin (kamen erst 8.0.000.021 rein) und spätere Anpassungen für Gambio 3.10 ebenfalls nicht (8.0.000.026). Deswegen allgemein falls jemand ähnliche Probleme hat: Bitte erst die VARIO aktualisieren, danach die Schnittstelle nochmal ausspielen, da die Version der Gambio Schnittstelle an die VARIO gebunden ist. Mit der aktuellen Version (8.0.000.036) funktioniert aber nun auch der Artikelimport und Bestellexport wieder (Nur diese beiden getestet, der Rest sollte ebenfalls klappen)
  8. Hallo stetra, an dieser Stelle können wir nur raten was da schief läuft Würde deswegen vorschlagen, dass Sie mir die Shop-URL und FTP-Zugangsdaten via PN mitteilen damit ich die Schnittstelle auf etwaige Fehler untersuchen kann. Danach können wir weitere Einstellungen in der VARIO - falls danach nötig - vornehmen.
  9. @Barbara_B Dachte das hat bereits geklappt... Da die Tabelle vario_vet von der nächsten Version (7.1.010.001) sowieso bereits angelegt wurde, können wir die "Version" überspringen. Die Version der Schnittstelle ist in Gambio in der configurations Tabelle hinterlegt. So kann man dies selektieren (Nur zur Info): SELECT configuration_value FROM configuration WHERE configuration_key = 'VARIO_VERSION_TAG' Dann setzen wir die Version einfach manuell auf 7.1.010.001 um das erneute Anlegen der vario_vet Tabelle zu überspringen UPDATE configuration SET configuration_value = '7.1.010.001' WHERE configuration_key = 'VARIO_VERSION_TAG' Dann würde er automatisch in die nächste Version 7.1.011.001 reinspringen, da muss man sich ggf. etwas rantasten um zu sehen wo es das letzte mal bei den Updates stehengeblieben ist. Alternativ kann man die Version in der configuration Tabelle komplett zurücksetzen (0) und die angelegten VARIO Tabellen löschen. Dann müsste alles von vorne anfangen, wobei es hier auch unklar ist ob er komplett durchläuft da dies beim ersten Mal auch nicht komplett durchlief. Edit: Man kann die SQLs im Administrationsbereich von Gambio unter Toolbox -> SQL ausführen
  10. Wunderbar, damit können wir schon was anfangen @Barbara_B Genau, das ist auch gut so! Am Ende muss oben in der Leiste Version 8.0.000.000 stehen (Die Seite muss ggf. ein paar Mal neu geladen werden), dann sind alle DB Updates durch und kannst es mit der Replikation nochmal probieren, da vorher auf jeden Fall bei den SQL Queries in einen Fehler lief. @Comrep Hier sieht es Datenbanktechnisch schon gut aus, hast bereits die Version 8.0.000.000. Versuch einfach mal (z.B. bei der Artikelreplikation) die aufgerufenen URL aus der Replikation zu Kopieren und mit Verbose Parameter aufzurufen, dann müsste die komplette Ausgabe im Browserbildschirm zu sehen sein. Da müsste alles ersichtlich sein wo ggf. ein Problem vorliegt. (Also z.B. http://meinshop.de/admin/vario_import7.php?Aktion=Replikation&DateiName=ART_00001.exp&Verbose für ART_00001.exp) @Barbara_B Falls es immer noch nicht funktioniert wäre das auch für dich der nächste Schritt
  11. Hallo zusammen, @Barbara_B Wenn bei der Erstellung von eigenen Datenbanktabellen was "schief läuft" könnt ihr unter /admin/vario/ die Datei key.vario temporär umbenennen (Damit die API ohne key erreichbar ist) und die URL https://meinshop.de/admin/vario_dbupdates7.php?Verbose aufrufen, damit werden die Datenbankupdates nochmal manuell angestoßen. Dann kann die zuvor umbenannte key.vario Datei wieder auf den Originalnamen zurückgesetzt werden. @Tobey Weiß nicht wie weit hier die Einrichtung aktuell ist, aber auf den Screenshot sehe ich den ISO - Code in der URL (https://meinshop.de/de/). Die Shop-URL darf in die VARIO nur ohne virtuelle URL hinterlegt werden, da sonst ausgegangen wird, dass der Shop unter https://meinshop.de/ im Unterverzeichnis /de/ liegt, somit wird entsprechend die URL weiter aufgebaut - https://meinshop.de/de/admin/... Falls weiterhin Fehler bei der Replikation auftauchen, obwohl die EXP - Dateien (unter /import/vario/files/) geschrieben werden, dann bitte einmal den Eintrag aus der error.log Datei hier im Forum posten, dann können wir auch genauer auf die Fehler eingehen. Wenn nichts ins error.log reingeschrieben wird, dann zuerst wie oben beschrieben key.vario umbenennen, die aufgerufene URL ins Browserfenster kopieren und Verbose Parameter (?Verbose | &Verbose) anhängen und aufrufen, dort wird der ganze Verlauf sichtbar sein. Am besten davon dann auch einen kompletten Screenshot posten, damit wir dies besser nachverfolgen können.
  12. Hallo rene, das ist richtig und war als Workaround für Gambio 3.9 mit DSGVO Update Paket eingebaut worden, da wegen den Service Pack die Session nicht gestartet wurde. Das Problem besteht mit Gambio 3.10 (Dort ist das DSGVO Service Pack bereits integriert) nicht mehr, deswegen ist es auch in neueren Versionen der Schnittstelle auch nicht mehr enthalten.
  13. An der Stelle ggf. nochmal interessante Information für Plesk Nutzer: Wenn Sie sich in Plesk Verbindungsdaten anzeigen lasst, wird dort der DB-Host immer mit der Portnummer angezeigt (HOST:Port). Damit kann die Schnittstelle aktuell noch nicht umgehen und wird keine Verbindung zur Datenbank Herstellen können. Dies wird in der Schnittstellenversion 8.0.000.020 behoben sein.
  14. Hallo Markus, dieses Problem hatten wir in einer älteren Version der Schnittstelle. Schicke Ihnen die aktuelle Schnittstelle nochmal via PN zu, dann müsste es funktionieren!
  15. Hallo Herr Schwadtke, lassen Sie uns das am besten direkt bei Ihnen angucken, um dem Problem auf den Grund zu gehen. Werde mich diesbezüglich bei Ihnen melden.
×
×
  • Neu erstellen...